Tired of all the dollar and backslash typing? Annoyed of seeing italic units? This may be THE END OF ALL YOUR PROBLEMS!

Manishearth INC.\$^{\mathrm{TM}}\$ has created this fantastic script which will do all (well, almost) the job for you!

No more tired fingers, no more sloppy units, no more slow typing...ALL THE POWER OF HOTKEYS!

[Serious mode: ON]

It's a script that Manishearth from Physics.SE created for helping in inserting formulas. It adds both hotkeys and editor buttons to quickly insert math and inline math objects, and also for the mathrm{} command, which shall be used for inserting units (so you're not justified for being lazy!).

It can be installed from here, and it's also available as source code. But for using in Firefox you need Greasemonkey.

If you want you can also donate at me ;). (Whoops, I was in serious mode, wasn't I?)

share
1  
Note that inserting unicode characters for units is preferred over MathJax as it loads faster. –  tyblu May 5 '12 at 20:48
    
@tyblu true, but it's not very consistent with the formula then.. –  clabacchio May 6 '12 at 9:19
1  
I would say that if you don't need MathJax and just need a unit, then use unicode. If you already have other MathJax then might as well use the units in MathJax. –  Kellenjb May 6 '12 at 16:36
    
If you're just putting units in plain text, use AHK shortcuts to insert Unicode units: gist.github.com/823381 Type kohm and it becomes , in any text field in any application. –  endolith May 15 '12 at 17:49
    
Just installed it and I get nothing added to the edit box, any ideas? –  Oli Glaser Aug 19 '12 at 21:50
    
@endolith - tried using your script and it does not encode correctly for me. For instance the mohm turns into mΩ;. I have tried messing around with encodings but I can't seem to get it to work. The only thing that works is using e.g. :c1*:kohm::kΩ, but then that wouldn't work elsewhere. Any thoughts would be appreciated. –  Oli Glaser Aug 19 '12 at 21:52
    
@OliGlaser: oh oops, it probably requires the unicode L version l.autohotkey.net –  endolith Aug 20 '12 at 1:39
    
@endolith - ahh, thanks for the quick reply, I'll give it a try. –  Oli Glaser Aug 20 '12 at 3:00
    
@endolith - that sorted it, working fine now. Thanks! –  Oli Glaser Aug 20 '12 at 4:26
add comment

1 Answer

Note to users who installed it before 5/5/12 (3:51 PM UTC):

The script no longer needs to be updated (most updates include the addition of more sites/buttons and tweaks like tooltips). It auto-fetches the updates now.

I suggest you uninstall/reinstall it to run this one-time update

How to uninstall:

  • Chrome: Settings>Tools>Extensions. Find the script and delete it
  • Firefox: Open the GM settings and remove the script

Then re-install normally (click here)

share
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .